UVA 11920 - 0 s, 1 s and ? Marks(贪心)

  0 s, 1 s and ? Marks 

Given a string consisting of 01 and ? only, change all the ? to 0/1, so that the size of the largest group is minimized. A group is a substring that contains either all zeros or all ones.

Consider the following example:

0 1 1 ? 0 1 0 ? ? ?

We can replace the question marks (?) to get

0 1 1 0 0 1 0 1 0 0

The groups are (0) (1 1) (0 0) (1) (0) (1) (0 0) and the corresponding sizes are 1, 2, 2, 1, 1, 1, 2. That means the above replacement would give us a maximum group size of 2. In fact, of all the 24 possible replacements, we won't get any maximum group size that is smaller than 2.

Input 

The first line of input is an integer T ( T$ \le$5000) that indicates the number of test cases. Each case is a line consisting of a string that contains 01 and ? only. The length of the string will be in the range [1,1000].

Output 

For each case, output the case number first followed by the size of the minimized largest group.

Sample Input 

4
011?010???
???
000111
00000000000000

Sample Output 

Case 1: 2
Case 2: 1
Case 3: 3
Case 4: 14

题意:给定一个串有0,1,?。?可以变成0或1,要求构造出一个串,使得连续的0,1的最大值最小。

思路:贪心,把连续的0,1,?保存在一起,然后去判断,如果是0,1就直接算最大值,如果是?,就看前面和后面是0还是1,如果前后相同且?个数为奇数或前后不同?个数为偶数,那么肯定可以交替01是最小的,反之,就看前面一串多1还是后面一串多1或者中间串多1比较好,注意如果中间只有一个?,那么就不用考虑中间多1的情况。

代码:

#include <stdio.h>
#include <string.h>
#define max(a,b) (a)>(b)?(a):(b)
const int N = 1005;

int t, pn;
char str[N];
struct Point{
	int v, num;
} p[N];

void init() {
	scanf("%s", str);
	memset(p, 0, sizeof(p));
	int len = strlen(str); pn = 0;
	char c = '#';
	for (int i = 0; i < len; i++) {
		if (str[i] == c) {
			p[pn - 1].num++;
		}
		else {
			c = str[i];
			p[pn].v = str[i] - '0';
			p[pn++].num++;
		}
	}
}

int solve() {
	int ans = 1;
	for (int i = 0; i < pn; i++) {
		if (p[i].v == 0 || p[i].v == 1) {
			ans = max(ans, p[i].num);
		}
		else {
			if (ans >= 2 && p[i].num != 1) continue;
			if (i == 0 || i == pn - 1) continue;
			if (p[i - 1].v == p[i + 1].v && p[i].num % 2) continue;
			if (p[i - 1].v != p[i + 1].v && p[i].num % 2 == 0) continue;
			if (p[i - 1].num <= p[i + 1].num) {
				p[i - 1].num++;
				ans = max(ans, p[i - 1].num);
			}
			else {
				p[i + 1].num++;
				ans = max(ans, p[i + 1].num);	
			}
		}
	}
	return ans;
}

int main() {
	int cas = 0;
	scanf("%d", &t);
	while (t--) {
		init();
		printf("Case %d: %d\n", ++cas, solve());
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值