ACM Parliament

Parliament

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished.
You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.
Input
The input file contains a single integer N (5<=N<=1000 ).
Output
Write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces.
Sample Input
7
Sample Output
3 4
Hint
Source
Northeastern Europe 1998 

类似于找子序列,就是将n进行拆分N=a1+a2+a3+a4+...+an.

#include<bits/stdc++.h>
using namespace std;
int main()
{
int n;
int count;
while(scanf("%d",&n)!=EOF)
{
int i,num=0;
int sum=0;
int a[1001];
memset(a,0,sizeof(a));
//1不能被拆分,所以从2开始累加,一直到n 
for(i=2;sum+i<=n;i++)
{
sum=sum+i;
a[++num]=i;
}

if(sum==n)
{
for(int j=2;j<i-1;j++)
  cout<<j<<" ";
cout<<i-1<<endl;
}
//否则从最大项开始,逐渐累加,一直到n为止 
else
{
count=num;
while(n-sum>0)
{
a[num]++;
num--;
sum++;
if(num<=0)
  num=count;
}
}
for(int j=1;j<count;j++)
{
cout<<a[j]<<" ";
}
cout<<a[count]<<endl;
}
return 0;

}

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,i=4,m=5,j;
    cin>>n;
    while (m<n) 
          m=m+i++;
    j=m-n;
    m=2;
    if (j==1)
    {
          m=3;
          j=i-1;
          i++;
    }
    while (m<i-1)
    {
          if (m!=j)
                cout<<m<<" ";
          m++;
    }
    cout<<i-1<<endl;
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值