Description
Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).
Input
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
Output
Print exactly one line for each test case. The line should contain the integer d(A).
Sample Input
1 10 1 -1 2 2 3 -3 4 -4 5 -5
Sample Output
13
Hint
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.
解题思路:
使用普通的m字段和的算法会超时,优化方法是用res[0][j]记录max(res[i-1][j] ) (i-1<=t<=j)
代码:
//912K
438MS
#include<iostream>
using namespace std;
int a[50001];
int res[2][50001];
int main()
{
int t,n;
cin>>t;
while(t--)
{
cin>>n;
for(int i=1;i<=n;i++)
scanf("%d",a+i);
int max1;
memset(res[0],0,sizeof(res[0]));
for(int i=1;i<=2;i++)
{
res[1][i]=res[1][i-1]+a[i];
max1=res[1][i];
//理解此段代码
for(int j=i+1;j<=n;j++)
{
res[1][j]=max(res[1][j-1],res[0][j-1])+a[j];
res[0][j-1]=max1;
if(max1<res[1][j])
max1=res[1][j];
}
}
max1=res[1][2];
for(int i=2;i<=n;i++)
if(max1<res[1][i])
max1=res[1][i];
cout<<max1<<endl;
}
system("pause");
return 0;
}