折磨我一上午的题

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:

Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.

这题实在太烦人了,在vj上面怎么也交不上去,要么运行错误,要么超时,我前前后后交了10次左右

没有通过的代码就不在这里复制了,把正确的写一下吧(朋友的)

#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
#include<cmath>
#define INF 0x3f3f3f3f
using namespace std;
int f[50009],ff[50009],l[50009],r[50009];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int a[50009],i,n;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(f,0,sizeof(f));
        memset(ff,0,sizeof(ff));
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        f[1]=a[1];
        ff[n]=a[n];
        l[1]=a[1];
        r[n]=a[n];
        for(i=2;i<=n;i++)
        {
            f[i]=max(f[i-1]+a[i],a[i]);
            l[i]=max(l[i-1],f[i]);
        }
        for(i=2;i<=n;i++)
        {
            f[i]=max(f[i],f[i-1]);
        }
        int ans=-INF;
        for(i=n-1;i>=1;i--)
        {
            ff[i]=max(ff[i+1]+a[i],a[i]);
            r[i]=max(ff[i],r[i+1]);
            ans=max(ans,f[i]+ff[i+1]);
        }
        printf("%d\n",ans);
    }
}

//仅是笔记,方便以后复习

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

季沐晴

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值