poj 2533 Longest Ordered Subsequence

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 28661 Accepted: 12445

Description

A numeric sequence of   ai  is ordered if   a1  <   a2  < ... <   aN. Let the subsequence of the given numeric sequence ( a1,   a2, ...,   aN) be any sequence ( ai1,   ai2, ...,   aiK), where 1 <=   i1  <   i2  < ... <   iK  <=   N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion
 
题目要求的是最长上升子序列(不一定要连续),最简单的办法是扫描两遍(两个for循环),时间复杂度为O(n^2),一般情况下,对于较大的数字是绝对过不了的,一定会爆掉,比较好的算法是动态规划+贪心,时间复杂度为O(lnogn),主要是利用了二分的思想。
好久没有写 代码了,这个代码居然提交了8、9次才AC掉。哎,看来这个东西必须天天写写才行啊。
下面是AC掉的代码:

#include<iostream>
using namespace std;
int Arr[1001];

int main()
{
    int N;
    int i;
    int temp;
    cin>>N;
    int top=0;
    Arr[0]=-1;
    for(i=0; i<N; i++)
    {
        cin>>temp;
        if(temp>Arr[top])
            Arr[++top]=temp;
        else
        {
            int left=1;
            int right=top;
            int mid;
            while(left<=right)
            {
                mid=(left+right)>>1;
                if(temp>Arr[mid])
                {
                    left=mid+1;
                }

                else
                {
                    right=mid-1;
                }

            }
            Arr[left]=temp;
        }
    }
    cout<<top<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值