poj3140(dfs) Contestants Division

Contestants Division
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7292 Accepted: 2066

Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers st, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1

Source

Memory: 7540 KB Time: 704 MS Language: C++ Result:  Accepted
本题大意是给你一个无向树,让你求树中一个节点跟那边组合两边权值差最小(或者说任意去掉其中的一条边后两个部分权值差最小),这个题的m其实就是n-1,说的那么大其实就是唬人的,写好了之后一直WA, 在discuss上面看到的错误好多是因为minn的初始值取小了(我觉得比较好的解决办法是令minn=sum)或者没用long long,__int64或者long long、__int64的abs()问题(这个求绝对值的函数最好是自己手写一个),然而这都不是我要说的重点,因为这些我都注意到了还是WA,最后我发现。。。。原来是我用vector的时候又忘了初始化,太坑爹了,希望后面做这题的人注意啊
#include<iostream>
#include<stdio.h>
#include<vector>
#include<string.h>
#include<cmath>
using namespace std;

struct tree{
	__int64 val,nod;
	vector<int>son;
}f[100050];
int vis[100050],n,m;
__int64 sum,minn;

void dfs(int x)//深搜没话说
{
	int i,j;
	__int64 tem;
	vis[x]=1;
	for(i=0;i<f[x].son.size();i++)
	{
		if(!vis[f[x].son[i]])
		{
			dfs(f[x].son[i]);
			f[x].nod+=f[f[x].son[i]].nod;
		}
	}
	tem=sum-f[x].nod-f[x].nod;//这个就是用来算两边差值的
	tem=tem>0?tem:(-tem);//取绝对值
	if(minn>tem)
		minn=tem;
}

int main()
{
	int i,j,k,a,b,c=0;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0&&m==0)
			break;
		c++;
		memset(vis,0,sizeof(vis));
		sum=0;
		for(i=0;i<=n;i++)
		f[i].son.clear();//用vector一定要记得初始化
		for(i=1;i<=n;i++)
		{
			scanf("%I64d",&f[i].nod);
			sum+=f[i].nod;
		}
		minn=sum;
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			f[b].son.push_back(a);//双向的
			f[a].son.push_back(b);
		}
		dfs(1);
		printf("Case %d: %I64d\n",c,minn);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值