sdut——GCC

题目描述

The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages.  But it doesn’t contains the math operator “!”.

In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)

We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m. 

输入

The first line consists of an integer T, indicating the number of test cases.

Each test on a single consists of two integer n and m. 

0 < T <= 20
0 <= n < 10 100 (without leading zero) 
0 < m < 1000000 

输出

Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m. 

示例输入

1 10 861017 

示例输出

593846

当n>m的时候,n%m==0,所以只要加到m-1个数的阶乘即可

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
char s[107];
int main()
{
	int t;
	cin>>t;	
	while(t--)
	{
		long long  m;
		 scanf("%s%lld",&s,&m);
		long long sum=1;
		long long number=0;
		long long count=1;
        int len=strlen(s);
	    if(len>7)
	    {
    		number=m-1;
    	}
    	else
    	{
	    	for(int i=0;i<len;i++)
	    	{
	    		number=number*10+(s[i]-'0');
	    	}
	    }
	    if(number>=m)
	    number=m-1;
	    for(int i=1;i<=number;i++)
	    {
    		count=(i*count)%m;
    		sum=(sum+count)%m;   		
    	}
    	cout<<sum%m<<endl;
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值