poj——1985——Cow Marathon

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

题意:输入n,m,紧接着输入m行,每一行有四个数,分别表示A,B,A、B之间的距离,方向,输出最远的两点之间的距离

分析:树的直径问题经典,两遍bfs

一开始任取一个点进行搜索查找距离点u最远的点v和长度,

然后第二次bfs从第一次的点v找出距离v最远距离的点的路径长度

如果u在最长路上,那么v一定是最长路的一端

若u不在最长路上,那么有u到v的路与最长路一定有一个交点c,并且(c->v)与最长路的后半段是重合的,即v一定是最长路的一端

F1——(13)——F6——(9)——F3

|

(3)

|

F4——(20)——F2

|

(2)

|

F7

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <vector>
using namespace std;
const int M=80005;
struct node
{
    int to;
    int len;
    int next;
}Node[M];
int n,m,temp;
int dist[M],vis[M],head[M],ans,num;
void add(int u,int v,int w)
{
    Node[num].to=v;
    Node[num].len=w;
    Node[num].next=head[u];
    head[u]=num++;
}
int bfs(int u)
{
    memset(vis,0,sizeof(vis));
    int front=0,rear=0;
    int q[M];
    vis[u]=1;
    dist[u]=0;
    q[rear++]=u;

    while(front<rear)
    {
        for(int k=head[q[front]];k!=-1;k=Node[k].next)
        {
            if(!vis[Node[k].to])
            {
                dist[rear]=dist[front]+Node[k].len;
                q[rear]=Node[k].to;
                vis[q[rear]]=1;
                if(dist[rear]>ans)
                {
                    ans=dist[rear];
                    temp=q[rear];
                }
                rear++;
            }
        }
        front++;
    }
    return ans;
}
int main()
{
   while(cin>>n>>m)
   {
       memset(head,-1,sizeof(head));
       num=0;
       ans=0;
       int u,v,w;
       char c;
       for(int i=0;i<m;i++)
       {
           cin>>u>>v>>w>>c;
           add(u,v,w);
           add(v,u,w);
       }
       bfs(1);
       cout<<bfs(temp);
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值