Problem Description
给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
Input
第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。
第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。
Output
每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
Sample Input
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
Sample Output
no yes
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
char mat[105][105];
int visited[105][105];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int m,n;
int maxturn;
class node
{
public:
int x;
int y;
int turn;
};
node s1,e1;
int judge(int x,int y)
{
if(x>=1 && x<=m && y>=1 && y<=n && mat[x][y]=='.')
return 1;
else
return 0;
}
int bfs(node st,node ed)
{
if(st.x==ed.x && st.y==ed.y) //特殊判断
return 1;
memset(visited,0,sizeof(visited));
queue<node> q;
node first,next;
first.x=st.x;
first.y=st.y;
first.turn=-1;
visited[first.x][first.y]=1;
q.push(first);
while(!q.empty())
{
first=q.front();
q.pop();
for(int i=0;i<4;i++)
{
next.x=first.x+dir[i][0];
next.y=first.y+dir[i][1];
while(judge(next.x,next.y)==1)
{
if(visited[next.x][next.y]==0) //不能因为不能访问就不找了
{
visited[next.x][next.y]=1;
next.turn=first.turn+1;
if(next.x==ed.x && next.y==ed.y && next.turn<=maxturn)
return 1;
q.push(next);
}
next.x+=dir[i][0];
next.y+=dir[i][1];
}
}
}
return 0;
}
int main()
{
int testcase,tx1,ty1,tx2,ty2;
cin>>testcase;
while(testcase--)
{
cin>>m>>n;
for(int i=1;i<=m;i++)
{
for(int j=1;j<=n;j++)
{
cin>>mat[i][j];
}
}
cin>>maxturn>>tx1>>ty1>>tx2>>ty2;
s1.x=ty1;
s1.y=tx1;
e1.x=ty2;
e1.y=tx2;
if(bfs(s1,e1)==1)
cout<<"yes"<<endl;
else
cout<<"no"<<endl;
}
return 0;
}