poj 1019 数论

Number Sequence
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 31517Accepted: 8948

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2

Source

 

 

这个题目的意思是说求出给出的位数所代表的数字是多少,具体分析看我的代码后面,我也是看了大神的代码,唉,自己实在太水了

 

#include<iostream>
#include<cstdio>
#include<cmath>
#define M 40000
using namespace std;
unsigned int a[M];
unsigned int s[M];
void table()
{
    int i,j;
    a[1]=1;
    s[1]=1;
    for(i=2;i<M;i++)
    {
        a[i]=a[i-1]+(int)log10((double)i)+1;
        s[i]=a[i]+s[i-1];
    }
}
int main()
{
    int i,j,k,t,n;
    table();
    scanf("%d",&t);
    while(t--)
    {
     scanf("%d",&n);
     i=1;
     while(n>s[i])
     {
         i++;
     }
     int pos=n-s[i-1];
     printf("%d pos\n",pos);

     int l=0;
     for(i=1;l<pos;i++)
     {
        l=l+(int)log10((double)i)+1;
     }
     printf("ll %d ll\n",l);
     printf("ii  %d\n",i);
     k=((i-1)/(int)pow(10,l-pos))%10;
     printf("%d\n",k);
    }
    return 0;
}
/*
1 12 123 1234 12345 123456 1234567 12345678 123456789 12345678910  1234567891011

1  3   6   10   15      21      28       36        45          56             69
123456789101112
             84                                                                                **
假如我们要求求出第83位的数是多少,
首先我们用S[],求出了前面有几位,我们求出69位前面那个s[i-1]是69,则pos=14;
这里的pos求出的也就是这第84位在这组数列的位置,不信就数数吧!!!

另外我们还要算一下这里前面的几位到底是多少,这里因为是15,所以计算到12就为止了。
l=15;
但是这里的i变成了13,所以i--;
12/(POW(10,1)=11;11%10=1;
但若我们求的84
pos=15;
l=15,还是我们求出的那个数的位数;
12/(POW(10,0)=12;
12%10=2;
*/


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值