//二分查找//Number Sequence------二O

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2…Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
Output
There should be one output line per test case containing the digit located in the position i.
Sample Input
2
8
3
Sample Output
2
2

解题思路:
用logn求每一个数的位数并存在数组d中,例如d[123]=3;
根据数组d递推可以求出每个序列s的位数并存在数组e中,例如e[10]=11(12345678910是11位);
根据数组e递推可以求出序列1到序列k的全部位数并存在数组f中,例如f[3]=6(112123是6位);

先求出数组d,e,f。
通过二分查找,找到i在数组f的什么位置,确定i在哪个序列里。
再通过二分查找e数组,确定i在序列的哪个数里。
最后通过计算得到i在这个数的第几位。

需要注意的是输入的i的范围可以达到int型的上限。而f中的最大值小于int型的上限,否则会溢出。所以必须单独讨论i大于f中的最大值的情况。

看到有一个人用lower_bound做的,但是这个函数我不太会。
先马一下。
http://blog.csdn.net/u010885899/article/details/48245249

#include<stdio.h>
#include<math.h>

int d[31268],e[31268],f[31268];

void init()
{
    e[0]=0;
    f[0]=0;
    for(int i=1;i<31268;i++)
    {
        d[i]=log10((double)i)+1;
        e[i]=e[i-1]+d[i];
        f[i]=f[i-1]+e[i];
    }
}

int search(int a[],int low,int high,int target)
{
    while(low<=high)
    {
        int mid=(low+high)/2;
        if(a[mid]>target)
        {
            high=mid-1;
        }
        else if(a[mid]<target)
        {
            low=mid+1;
        }
        else
        {
            return mid;
        }
    }
    return low;
}

int main()
{
    init();
    int t,num,k,c,a,b,digit[10],ans;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&num);
        if(num>f[31267])
        {
            k=31268;
        }
        else k=search(f,1,31267,num);//确定i在序列Sk中
        c=num-f[k-1];//在序列中是第c位
        a=search(e,1,k,c);//确定i在哪个数里
        b=c-e[a-1];//确定i在第几位
        ans=a/(int)pow(10,(double)d[a]-b);
        ans=ans%10;
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值