Matrix hdu 2119 最小点覆盖

Matrix

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1603    Accepted Submission(s): 704


Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.
 

Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.
 

Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.
 

Sample Input
  
  
3 3 0 0 0 1 0 1 0 1 0 0
 

Sample Output
  
  
2
 

Author
Wendell
 

Source
 

Recommend
威士忌




/*

应该讲在这个题目是不难的,以横作为一个X集合,
列作为一个Y集合,1为集合之间的关系,然后求出
最小覆盖要求用最少的点(X集合或Y集合的都行)
让每条边都至少和其中一个点关联,最少的点=最大
匹配数




*/




#include<stdio.h>
#include<string.h>
using namespace std;
#define M 200
int n,m;
int link[M],g[M][M];//g[][]是算地图,link代表联系
int map[M][M];
bool vis[M];

bool find(int i)
{
    for(int j=1;j<=m;j++)
    if(g[i][j]&&!vis[j])
    {
        vis[j]=true;
        if(link[j]==0||find(link[j]))
        {
            link[j]=i;
            return true;
        }
    }
    return false;
}
int main()
{
    while(scanf("%d",&n),n)
    {
        scanf("%d",&m);
        memset(g,0,sizeof(g));
        memset(link,0,sizeof(link));
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            scanf("%d",&map[i][j]);
            if(map[i][j]==1)
            g[i][j]=1;
        }
        int num=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(find(i))
            {
                //printf("fdsjklfsd");
                num++;
            }

        }
        printf("%d\n",num);
    }
    return 0;
}





 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值