hust 1010 KMP算法求最小循环节

1010 -- The Minimum Length

Time Limit: 1S Memory Limit: 128MB

Submissions: 534 Solved: 186
DESCTIPTION
There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.
INPUT
Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.
OUTPUT
For each line, output an integer, as described above.
SAMPLE INPUT
bcabcab
efgabcdefgabcde
SAMPLE OUTPUT
3
7
HINT

SOURCE


这个题目的意思是说给出一a字符串,多次复制,取出其中一部分为b,求出其中最小长度的a是多少,实际上这个题目的意思是在求一个字符串中的最小循环节,求出next数组,取next[t],也就是整个字符串中前缀和后缀的最大匹配值,列如bcabcab中next[7]=4,其中bcab,和bcab,其中b被重复利用了两次,所以可以求出其中的最小循环节就是7-4=3,也就是cab了,今天早上吃面条时吃玲玲小朋友讲了kmp,好不容易终于会了,实在不容易,这个面条吃的值,吃的值!!!!


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int t;
char s[1000005];
int next[1000005];
void getNext()
{

     int j=-1;
     int i=0;
     next[0]=-1;
     t=strlen(s);
     while(i<t)
     {
       if((j==-1)||(s[i]==s[j]))
       {
           i++;
           j++;
           next[i]=j;
       }
       else
       {
           j=next[j];
       }
     }
}
int main()
{
    int i,j,k;
    while(scanf("%s",s)!=EOF)
    {

     t=strlen(s);
     getNext();
     printf("%d\n",t-next[t]);
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值