hdu-3817-Triangle

Triangle

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1107 Accepted Submission(s): 690


Problem Description
You are given the side lengths of a triangle, determine is it an acute triangle, right triangle or obtuse triangle.

Input
The first line contains an integer T indicating the number of test cases.
For each test case, there is a single line contains three integer A, B and C indicating the side lengths of the triangle. (You can assume it is a valid triangle)

Technical Specification

1. 1 <= T <= 50
2. 1 <= A,B,C <= 100

Output
For each test case, output the case number first, then output "Acute triangle", "Right triangle" or "Obtuse triangle".

Sample Input
  
  
3 2 2 2 4 8 5 3 4 5

Sample Output
  
  
Case 1: Acute triangle Case 2: Obtuse triangle Case 3: Right triangle
#include<iostream>
using namespace std;
int main()
{
    int s,a,b,c,t,d=1;
    cin>>s;
    while(s--)
    {
        cin>>a>>b>>c;
        if(a<b)
        {
            t=a;
            a=b;
            b=t;
        }
        if(a<c)
        {
            t=a;
            a=c;
            c=t;
        }
        cout<<"Case "<<d++<<": ";
        if(b*b+c*c==a*a) cout<<"Right triangle"<<endl;
        else if(b*b+c*c<a*a) cout<<"Obtuse triangle"<<endl;
        else cout<<"Acute triangle"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值