Find a multiple

Find a multiple
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5029 Accepted: 2174 Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2

2

3

 

#include<stdio.h>
int main()
{
    int m,n,i,j,k,s[100000],d[100000],sum,e;
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;d[1]=0;
        for(i=1;i<=n;i++)
        scanf("%d",&s[i]);
        for(i=1;i<=n;i++)
        {
            e=0;
            sum+=s[i];
            k=sum%n;
            if(k==0)
            {
                printf("%d\n",i);
                for(j=1;j<=i;j++)
                {
                    printf("%d\n",s[j]);
                    e=1;
                }
            }
            else
            {
                for(m=1;m<i;m++)
                {
                    if(k==d[m])
                    {
                        printf("%d\n",i-m);
                        for(j=m+1;j<=i;j++)
                        printf("%d\n",s[j]);
                        e=1;
                        break;
                     }
                }
            if(e) break;
            else d[m]=k;
            }
            if(e) break;
        }
    }
    return 0;
}

利用抽屉原理(鸽巢原理),当前n项和对所给数求余为0时,说明能整除,此时前n项和为所给数的整倍数,如果不等0,则后一个余数与前面余数有相同时,就从这一位开始,到前面相同余数的后一位之和为所给数的整倍数。

类比poj3370题

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值