B - Find a multiple(抽屉原理)

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input
The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output
In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.
Sample Input
5
1
2
3
4
1
Sample Output
2
2
3

题意:给一个数字n,再给n个数,看这n个数能不能组成组成n倍,能的话输出有几个数可以组成,然后输出他们。不能就输出0

抽屉原理 把多于n+1个的物体放到n个抽屉里,则至少有一个抽屉里的东西不少于两件 用sum[i]来记录和 如果sum[i]%n==0 那就是1-i 如果不等于0 因为至少一个抽屉里的东西不少于两个 所以存在一个i 一个j sum[i]%n与sum[j[%n 相等 那么i和j就是答案 因为余数相等 相减就是n的倍数

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<math.h>
#include<iostream>
#include<vector>
#include<set>
#include<stack>
#include<map>
#include<queue>
typedef long long ll;
using namespace std;
const int N=10000+5;
const int INF=0x3f3f3f3f3f;
int a[N],sum[N],vis[N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(sum,0,sizeof(sum));
        memset(a,0,sizeof(a));
        memset(vis,-1,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];
        }
        for(int i=1;i<=n;i++)
        {
            if(sum[i]%n==0)
            {
                //printf("**\n");
                printf("%d\n",i);
                for(int j=1;j<=i;j++)
                {
                    printf("%d\n",a[j]);
                }
                break;
            }
            if(vis[sum[i]%n]!=-1)
            {
                //printf("+++\n");
                printf("%d\n",i-vis[sum[i]%n]);
                for(int j=vis[sum[i]%n]+1;j<=i;j++)
                {
                    printf("%d\n",a[j]);
                }
                break;
            }
            vis[sum[i]%n]=i;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值