Find a multiple (抽屉原理)

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input
The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output
In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.
Sample Input
5
1
2
3
4
1

Sample Output

2
2
3

题意:在n个数中找出和是n的倍数的一组数。

抽屉原理: 把多于n个的物体放到n个抽屉里,则至少有一个抽屉里有2个或2个以上的物体。

而这道题怎么与抽屉原理有关:sum[i]表示前i个数的和,如果其中有n的倍数(sum[i]%i==0),就从1到i输出a[i];如果这里没有n的倍数,1<=i<=n,所以sum值有n个,而n的余数[1,n-1],共n-1个数,所以n个sum值中一定有相同的。如果sum[j]%n==sum[i]%n;则sum[j]-sum[i]一定为n的倍数。

#include<stdio.h>
#include<string.h>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
int a[10005];
ll sum[10005];
int mod[10005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(sum,0,sizeof(sum));
        memset(mod,-1,sizeof(mod));
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)
        {
            sum[i]=sum[i-1]+a[i];
            if(sum[i]%n==0)//直接从第一个到i输出
            {
                printf("%d\n",i);
                for(int j=1;j<=i;j++)
                    printf("%d\n",a[j]);
                break;
            }
            if(mod[sum[i]%n]!=-1)//之前出现过这个余数,sum[i]-sum[j]定为n的倍数,输出a[j+1]~a[i]
            {
                int j=mod[sum[i]%n];
                printf("%d\n",i-j);
                for(int k=j+1;k<=i;k++)
                    printf("%d\n",a[k]);
                break;
            }
            mod[sum[i]%n]=i;//记录这个余数值所在的位置
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值