Find a multiple 抽屉原理(鸽巢)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7062 Accepted: 3092 Special Judge
Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.
Sample Input

5
1
2
3
4
1
Sample Output

2
2
3
————————————————

题意:给出n个数,任选几个数,使其和为n的倍数。

编程思想:鸽巢原理的简单应用。设前k项和Sk表示a1+a2+……ak,如果Sk是n的倍数,那就直接取Sk了,否则S1~Sn除n的余数分布在1—(n-1)这n-1个数中,运用鸽巢原理,必然有两个的余数相同,即(Si%n)=(Sj%n),即(Sj-Si)%n=0,证毕。所以落在区间i+1至j的所有数的和就是n的倍数。

抽屉原理适用于n>=c,任选n个数,使其和为c的倍数。因为n个数的前缀和sum(1-n),有n种不同的值。如果那些sum modc都不等于0,且因为每个sum,modc以后结果一定在1~c-1,共c-1个值。所以必有至少两个sum%c结果一样。

#include<iostream> 
using namespace std;
typedef long long ll;
ll sum[10005];
ll a[10005];
ll mod[10006];
int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)cin>>a[i];
	for(int i=1;i<=n;i++)
	{
		sum[i]=sum[i-1]+a[i];
		if(sum[i]%n==0)
		{
			cout<<i<<endl;
			for(int j=1;j<=i;j++)cout<<a[j]<<endl;
			break;
		}
		if(mod[sum[i]%n])
		{
			cout<<i-mod[sum[i]%n]<<endl;
			for(int j=mod[sum[i]%n]+1;j<=i;j++)cout<<a[j]<<endl;
			break;
		}
		mod[sum[i]%n]=i;
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值