题目链接:https://www.patest.cn/contests/gplt/L2-006
题目:
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:7 2 3 1 5 7 6 4 1 2 3 4 5 6 7输出样例:
4 1 6 3 5 7 2
题意:根据二叉树的后序和中序遍历序列重构二叉树,输出二叉树的层次遍序列。
题解:前序:根左右;中序:左根右;后序:左右根根据对应位置递归建树。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<queue>
using namespace std;
const int MAX=30+5;
int post_order[MAX],in_order[MAX];
int level_order[MAX];
map<int,int> lch;
map<int,int> rch;
int t;
int build(int l1,int r1,int l2,int r2)
{
if(l1>r1) return 0;
int root=post_order[r1];
int i=l2;
while(in_order[i]!=root) i++;
int left_cnt=i-l2;
lch[root]=build(l1,l1+left_cnt-1,l2,l2+left_cnt-1);
rch[root]=build(l1+left_cnt,r1-1,l2+left_cnt+1,r2);
return root;
}
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int N;
while(scanf("%d",&N)!=EOF)
{
for(int i=0;i<N;i++)
scanf("%d",&post_order[i]);
for(int i=0;i<N;i++)
scanf("%d",&in_order[i]);
t=0;
int root=build(0,N-1,0,N-1);
queue<int>tree;
tree.push(root);
int flag=1;
while(!tree.empty())
{
if(flag!=1) printf(" ");
flag=0;
int top=tree.front();
printf("%d",top);
tree.pop();
if(lch[top]!=0)tree.push(lch[top]);
if(rch[top]!=0)tree.push(rch[top]);
}
printf("\n");
}
return 0;
}