HDU 1116 并查集

Play on Words

 

Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
 


 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
 


 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
 


 

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok
 


 

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.

给定一些单词,判断能否首尾连接起来

 首先需要判断是否连通,用并查集,看最后的有根树是否唯一

判断唯一之后,需要判断是否构成欧拉回路或者通路(根据节点的度)

// 欧拉通路—通过图中每条边一次且仅一次,并且过每一顶点的通路。
// 欧拉回路—通过图中每条边一次且仅一次,并且过每一顶点的回路。
// 欧拉通路:图连通;图中只有0个或2个度为奇数的节点
// 欧拉回路: 通过图中每条边且只通过一次,并且经过每一顶点的回路。

#include <iostream>
using namespace std;
int p[1111];
int vis[111];
int in[111];
int out[111];
int find(int x)
{
	if(x!=p[x])
		p[x]=p[find(p[x])];
	return p[x];
}
void merge(int x,int y)
{
	p[find(x)]=find(y);
}
bool euler()
{
// 欧拉通路—通过图中每条边一次且仅一次,并且过每一顶点的通路。 
// 欧拉回路—通过图中每条边一次且仅一次,并且过每一顶点的回路。 
// 欧拉通路:图连通;图中只有0个或2个度为奇数的节点
// 欧拉回路: 通过图中每条边且只通过一次,并且经过每一顶点的回路。
	int v[27],C=0;
	for(int i=1;i<=26;i++)
		if(vis[i]&&in[i]!=out[i])
			v[C++]=i;
	if(C==0)
		return true;
	int a=in[v[0]],b=in[v[1]];
	int c=out[v[0]],d=out[v[1]];
	if(C==2&&((a-c==1&&d-b==1)||(c-a==1&&b-d==1)))
		return true;
	return false;
}
int main()
{

	int t,n,i;
	char s[1111];
	scanf("%d",&t);
	while(t--)
	{
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		memset(vis,0,sizeof(vis));
		scanf("%d",&n);
		for(i=1;i<=26;i++)
			p[i]=i;
		for(i=1;i<=n;i++)
		{
			scanf("%s",s);
			int x=s[0]-'a'+1;
			int y=s[strlen(s)-1]-'a'+1;
			merge(x,y);
			in[y]++;
			out[x]++;
			vis[x]=vis[y]=1;
		}
		int cnt=0;
		for(i=1;i<=26;i++)
			if(vis[i]&&p[i]==i)
				cnt++;
		if(cnt>1)
			printf("The door cannot be opened.\n");
		else if(euler())
			printf("Ordering is possible.\n");
		else
			printf("The door cannot be opened.\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值