HDU 1312 DFS

Red and Black


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.  
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile  
'#' - a red tile  
'@' - a man on a black tile(appears exactly once in a data set)  
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).  
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13


题意:

搜索与@相连在一起的'.'有多少个。DFS

代码:

#include <iostream>
using namespace std;
char map[21][21];
int cnt;//计数
int a,b;
int dire[4][2]={{-1,0},{1,0},{0,-1},{0,1}};//四个方向
int visit[21][21];//记录是否走过
int start_x,start_y;

void dfs(int x,int y)
{
	visit[x][y]=1;
	cnt++;
	for(int i=0;i<4;i++)
	{
		if(x+dire[i][0]>=0&&x+dire[i][0]<a&&y+dire[i][1]>=0&&y+dire[i][1]<b&&map[x+dire[i][0]][y+dire[i][1]]=='.'&&visit[x+dire[i][0]][y+dire[i][1]]==0)
			dfs(x+dire[i][0],y+dire[i][1]);
	}
}
int main()
{
	while(cin>>b>>a,(a||b))
	{
		cnt=0;
		memset(visit,0,sizeof(visit));
		for(int i=0;i<a;i++)
		{
			for(int j=0;j<b;j++)
			{
				cin>>map[i][j];
				if(map[i][j]=='@')
					start_x=i,start_y=j;//记录起始位置
			}
		}
		dfs(start_x,start_y);
		cout<<cnt<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值