HDU 1398 母函数

Square Coins




Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

Sample Input
  
  
2 10 30 0
 

Sample Output
  
  
1 4 27
 
题意:
题目限制只能使一个数的平方,例如放n=9时,
9的拆分数是这样算的:(1+x+x62+x^3)(1+x^4+x^8)(1+x^9)中x^9的系数
套用母函数模板,把其中的(i=2;i<=n;i++)改成(i=2;i*i<=n;i++)
在k遍历时候,k+=i改成k+=i*i..
 
#include <iostream>
using namespace std;
int c1[1111],c2[1111];
int mamafun(int n)//母函数
{
	int i,j,k;
	for(i=0;i<=n;i++)
		c1[i]=1,c2[i]=0;//初始化第一个式子(1+x+x^2+x^3+...)
	for(i=2;i*i<=n;i++)//从第二个才是乘入
	{
		for(j=0;j<=n;j++)
			for(k=0;k+j<=n;k+=i*i)//k+=i:(1+x+x^2+x^3..)、(1+x^2+x^4..)、(1+x^3+x^6+..)..
				c2[k+j]+=c1[j];
		for(j=0;j<=n;j++)//乘i-th表达式的结果赋值
			c1[j]=c2[j],c2[j]=0;//c2=0,因为c2每次是从一个表达式中开始的
	}
	return c1[n];
}
int main()
{
	int n;
	while(scanf("%d",&n),n)
		printf("%d\n",mamafun(n));
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值