HDU 1028 母函数

Ignatius and the Princess III


Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627


题意:

 4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
这样说明有五种可以组成4,给你一个数,存在几个这样的情况可以组成它。

母函数的应用,现在还不是很熟悉,刚学的..有点迷茫,但还是有点理解了,,

实际上就是就(1+x+x^2+x^3+...)(1+x^2+x^4+x^6+...)(1+x^3+x^6+x^9+...)(1+x^4+x^8+...)........

中x的n次方的系数

用母函数求解,其实就是一个式子一个式子乘进去..记录各个次方的系数

母函数的经典题目。

#include <iostream>
using namespace std;
int c1[1111],c2[1111];
int mamafun(int n)//母函数
{
	int i,j,k;
	for(i=0;i<=n;i++)
		c1[i]=1,c2[i]=0;//初始化第一个式子(1+x+x^2+x^3+...)
	for(i=2;i<=n;i++)//从第二个才是乘入
	{
		for(j=0;j<=n;j++)
			for(k=0;k+j<=n;k+=i)//k+=i:(1+x+x^2+x^3..)、(1+x^2+x^4..)、(1+x^3+x^6+..)..
				c2[k+j]+=c1[j];
		for(j=0;j<=n;j++)//乘i-th表达式的结果赋值
			c1[j]=c2[j],c2[j]=0;//c2=0,因为c2每次是从一个表达式中开始的
	}
	return c1[n];
}
int main()
{
	int n;
	while(~scanf("%d",&n))
		printf("%d\n",mamafun(n));
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值