HDU 1709 母函数

The Balance


 

Problem Description

 

Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 


 

Input

 

The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 


 

Output

 

For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 


 

Sample Input

 

  
  
3 1 2 4 3 9 2 1
 


 

Sample Output

 

  
  
0 2 4 5

 

题意:

给出n个物品及其重量,求1-sum(sum为着多个物品的总重量)

然后进行称量,看不能称出的价值有几个

其中不能称出的价值包括:直接称出的 和间接称出.以外的

母函数模板变形一下,,

数组要开大。切记

#include <iostream>
#include <cmath>
using namespace std;
int a[111];
int sum,n;
int cnt;
int c1[11111],c2[11111];
int main()
{
	int i,j,k;
	while(~scanf("%d",&n))
	{
		sum=cnt=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		c1[0]=1,c1[a[1]]=1;//第一个遍历
		int m=a[1];
		for(i=2;i<=n;i++)//第二个式子开始,2-n
		{
			for(j=0;j<=m;j++)//第j-th个式子
			{
				for(k=0;k<=a[i];k+=a[i])
				{
					c2[k+j]+=c1[j];//天平可加可减
					c2[abs(k-j)]+=c1[j];//减
				}
			}
			m+=a[i];
			for(j=0;j<=m;j++)
				c1[j]=c2[j],c2[j]=0;
		}
		for(i=1;i<=sum;i++)
			if(c1[i]==0)
				cnt++;//计算有几个不能称量
		printf("%d\n",cnt);
		if(cnt)//没有则不用输出
		{
			for(i=0;i<=sum;i++)
			{
				if(c1[i]==0)
				{
					printf("%d",i);
					if(cnt>1)printf(" ");
					else printf("\n");
					cnt--;
				}
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值