02-1. Reversing Linked List (25) PAT DBS打基础之练习

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
思路比较明显:已知链表的首结点地址,我们只需要依次查找下一个结点,就可以得到链表的顺序,然后我们按照题目要求,每k个元素输出一次就行, 不足k个元素直接原序输出。 此题比较坑的是第6组测试数据,输入的节点中有无效节点。
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<map>
#include<string>
#include<cstring>
using namespace std;
const int mx=100005;
typedef struct node{
	int add;
	int data;
	int nextAdd;
}Node; 
Node nod[mx],ans[mx];
int main()
{
	int first,n,k;
	while(scanf("%d %d %d",&first,&n,&k)!=EOF){ 
	int i=0,N=n;
	while(N--){
		scanf("%d",&i);
		nod[i].add=i;
		int t;
		scanf("%d",&t);
		nod[i].data=t;
		scanf("%d",&t);
		nod[i].nextAdd=t;		
	}
	int j=0;
	for(int i=first;;){
		ans[j].add=nod[i].add;
		ans[j].data=nod[i].data;
		j++;
		i=nod[i].nextAdd;
		if(i == -1) break;
	}	
	n=j;//处理无效结点。 
	int pre=0,stop=n/k*k-1;
	if(n%k==0) ans[n-1+k].add=-1;
	else ans[n-1].nextAdd=-1;
	//每k个结点逆序输出。 
	for(j=k-1;j<=stop;j+=k){
		int temp=j;
		while(temp > pre){ 
			printf("%05d %d %05d\n",ans[temp].add,ans[temp].data,ans[temp-1].add);
			temp--;		
		}
		pre=j+1;
		if(ans[j+k].add!=-1)
			if(n%k!=0 && j==stop) 
				printf("%05d %d %05d\n",ans[temp].add,ans[temp].data,ans[j+1].add);
			else printf("%05d %d %05d\n",ans[temp].add,ans[temp].data,ans[j+k].add);
		else 
			if(n%k==0)
				printf("%05d %d %d\n",ans[temp].add,ans[temp].data,ans[j+k].add);
	}
	if(n%k != 0){
		for(i=j+1-k;i<n;i++)
			if(ans[i].nextAdd!=-1)
				printf("%05d %d %05d\n",ans[i].add,ans[i].data,ans[i+1].add);
			else printf("%05d %d %d\n",ans[i].add,ans[i].data,ans[i].nextAdd);
		
	}   
}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值