02-1. Reversing Linked List(PAT 1074)

这题刚开始 以为用顺序表会比较方便

结果 到各种转换的时候,才发现用指针会方便很多。

推荐大家用顺序结构+指针做。不会出现我这种烦恼。


Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

#include<stdio.h>
#include<stdlib.h>
#define MAX 100004

struct Node{
	int left;
	int date;
	int right;
};

int iHead,N,K;
Node Nodelist[MAX];

void Print(int num){
	int temp = num;
	while(Nodelist[temp].right!=-1){
		printf("%.5d %d %.5d\n",temp,Nodelist[temp].date,Nodelist[temp].right);
		temp = Nodelist[temp].right;
	}
	
	printf("%.5d %d %d\n",temp,Nodelist[temp].date,Nodelist[temp].right);
}

void reverse(int k,int newhead,int sum){
	int temp=newhead;
	int i,add;
	for(i=0;i<k-1;i++)
		temp=Nodelist[temp].right;
	int first = temp;	
	for(i=0;i<k-1;i++){
		printf("%.5d %d %.5d\n",temp,Nodelist[temp].date,Nodelist[temp].left);
		temp = Nodelist[temp].left;
	}
	if(Nodelist[first].right!=-1){
		if(N-sum>=K){
			add = first;
			for(i = 0;i<K;i++)
				add = Nodelist[add].right;
			printf("%.5d %d %.5d\n",temp,Nodelist[temp].date,add);
		}
		else
			printf("%.5d %d %.5d\n",temp,Nodelist[temp].date,Nodelist[first].right);
	}
	else
		printf("%.5d %d %d\n",temp,Nodelist[temp].date,Nodelist[first].right);
}

int main(){
	int i;
	for(i=0;i<MAX;i++){
		Nodelist[i].left = -1;
		Nodelist[i].date = 0;
		Nodelist[i].right= -1;
	}
	scanf("%d %d %d",&iHead,&N,&K);
	int newadd,date,right;
	for(i=0;i<N;i++){
		scanf("%d %d %d",&newadd,&date,&right);
		Nodelist[newadd].date=date;
		Nodelist[newadd].right=right;
		if(right!=-1)
			Nodelist[right].left=newadd;
	}
	
	int temp = iHead;
	int len = 1;
	while(Nodelist[temp].right!=-1){
		len++;
		temp=Nodelist[temp].right;
	}
	
	if(K>len){
		Print(iHead);
		system("pause");
		return 0;
	}
	N=len;
	
	int sum=0;
	int newHead=iHead;
	if(K>1){
		while(N-sum>=K){
			sum+=K;
			reverse(K,newHead,sum);
			for(i=0;i<K;i++)
				newHead = Nodelist[newHead].right;
		}
		if(newHead!=-1)
		Print(newHead);
	}
	else
		Print(newHead);
		
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值