02-1. Reversing Linked List (25)
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, andNext is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 12309 2 33218Sample Output:
00000 4 33218 33218 3 12309 12309 2 00100 00100 1 99999 99999 5 68237 68237 6 -1
解题报告:
这题要注意的数据中节点组成的链表可能不只一个,所以要按照首地址来组成链表,链表可能只有一个节点。
先贴上自己渣渣代码,被嘲笑了。。。。。
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
const int oo = 0x7ffffff;
struct node{
char add[6];
int index;
char next[6];
bool operator < (const node& other) const {
return strcmp(add, other.add) < 0;
}
bool operator = (const node& other) {
strcpy(add, other.add);
index = other.index;
strcpy(next, other.next);
}
}nn,tmp;
vector<node> v;
vector<node> ans;
int main() {
char head[6];
int n, k;
scanf("%s %d %d", head, &n, &k);
for (int i = 0; i < n; i ++) {
scanf("%s %d %s", nn.add, &nn.index, nn.next);
v.push_back(nn);
}
sort(v.begin(), v.end());
while (1) {
strcpy(nn.add, head);
tmp = *lower_bound(v.begin(), v.end(), nn);
if(strcmp(head, tmp.add) == 0) {
ans.push_back(tmp);
strcpy(head, tmp.next);
} else break;
}
int i = 0;
int len = ans.size();
while (i + k - 1 < len) {
reverse(ans.begin() + i, ans.begin() + i + k);
i += k;
}
for (i = 0; i < len - 1; i ++) {
printf("%s %d %s\n",ans[i].add, ans[i].index,ans[i+1].add);
}
printf("%s %d -1\n",ans[i].add, ans[i].index);
return 0;
}
再贴上自己改邪归正后的代码:
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 100000;
struct Node {
int label;
int data;
int next;
};
vector<Node> ans;
Node node[MAXN];
int main() {
int n, tmp, k;
int a, b, c;
scanf("%d%d%d", &tmp, &n, &k);
while (n --) {
scanf("%d%d%d", &a, &b, &c);
node[a].label = a;
node[a].data = b;
node[a].next = c;
}
while (tmp != -1) {
ans.push_back(node[tmp]);
tmp = node[tmp].next;
}
int cnt = ans.size(), i = 0;
while(i + k - 1 < cnt) {
reverse(ans.begin() + i, ans.begin() + i + k);
i += k;
}
for (i = 0; i < cnt -1; i ++) {
printf("%05d %d %05d\n", ans[i].label, ans[i].data, ans[i+1].label);
}
printf("%05d %d -1\n", ans[i].label, ans[i].data);
return 0;
}