HDU-1518 Square(DFS)

Square

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 12
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

Source

University of Waterloo Local Contest 2002.09.21
此题需要优化时间,避免超时。。优化时间技巧可以学习。。。。。。。。。
#include <stdio.h>
#include<string.h>
int a[10000];
int vist[10000];
int sum;
int l;
int n;
int flag;
void Dfs(int t, int len, int index)
{
    

    if (t == 5)
    {
        flag = 1;
        return ;
    }

    if (len == l)
    {
        Dfs(t + 1, 0, 0);
        if (flag)//优化时间
        {
            return ;
        }
    }

    for (int i = index; i < n; i++)//从index开始优化时间
    {
        if (vist[i]==0 && a[i] + len <= l)
        {
            vist[i] = 1;
            Dfs(t, a[i] + len, i + 1);
            if (flag)//优化时间
            {
                return;
            }
            vist[i] = 0;
        }
    }
}

int main()
{
    int i,t;
    scanf("%d", &t);
    while (t--)
    {
        
        sum = 0;
        scanf("%d", &n);
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &a[i]);
            sum += a[i];
        }
        
        if (sum % 4 != 0)//简答的优化
        {
            puts("no");
            continue;
        }


        l = sum / 4;

       
        for (i = 0; i < n; i++)//有比边长大的边就不行
        {
            if (a[i] > l)
            {
                break;
            }
        }
        if (i != n)
        {
            puts("no");
            continue;
        }
       memset(vist, 0, sizeof(vist));
        flag = 0;
        Dfs(1, 0, 0);
        if (flag)
        {
            puts("yes");
        }
        else
        {
            puts("no");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值