1002. A+B for Polynomials (25)
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input2 1 2.4 0 3.2 2 2 1.5 1 0.5Sample Output
3 2 1.5 1 2.9 0 3.2
/**
作者:一叶扁舟
时间:14:48 2017/6/17
思路:
*/
#include <stdio.h>
#include <stdlib.h>
#define SIZE 1001
int main(){
int Ka, Kb;//a和b中各有多少个多项式
float A[SIZE] = {0};
float B[SIZE] = { 0 };
int e; float d;//分别表示指数和系数
int count = 0;//统计最终和的多项式的个数
scanf("%d",&Ka);
for (int i = 0; i < Ka; i++){
scanf("%d %f",&e,&d);
A[e] = d;
}
scanf("%d",&Kb);
for (int i = 0; i < Kb; i++){
scanf("%d %f",&e,&d);
B[e] = d;
}
//将两个多项式进行相加
for (int i = SIZE - 1; i >= 0; i--){
A[i] = A[i] + B[i];
if (A[i] != 0){//对应的系数不为0
count++;
}
}
//输出
printf("%d",count);
for (int i = SIZE - 1; i >= 0; i--){
if (A[i] != 0){
printf(" %d %.1f", i, A[i]);//注意格式输出
/*if (i != 0){//这样写有问题,当不存在指数0就结束时,此时就在输出后面多了一个空格这是不对滴!
printf(" ");
}*/
}
}
system("pause");
return 0;
}