PAT甲级真题及训练集(11)--1031. Hello World for U (20)

1031. Hello World for U (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1characters, then left to right along the bottom line with n 2 characters, and finally bottom-up along the vertical line with n 3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1 = n 3 = max { k| k <= n 2 for all 3 <= n 2 <= N } with n 1 + n 2 + n 3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor

提交代


/**
作者:一叶扁舟
时间:17:10 2017/6/25
思路:

*/
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define SIZE 10001

int main(){
	int n1, n2, n3;
	int N;//总共字符总数
	char cha[SIZE];
	scanf("%s",cha);
	//计算输入的字符总长度
	N = strlen(cha);
//	printf("长度:%d", N);
	n1 = (N + 2) / 3 - 1;//两侧的数量,不包含最后一行的字母
	n3 = n1;
	n2 = N - n1 - n3;//最后一行的长度
	char left[SIZE];
	char middle[SIZE];
	char right[SIZE];
	strncpy(left, cha, n1);
	strncpy(middle, cha + n1, n2);
	strncpy(right, cha + n1 + n2, n3);
	middle[n2] = '\0';
	
	for (int i = 0; i < n1; i++){
		//输出最左边的字符
		printf("%c", left[i]);
		//输出中间的空格
		for (int j = 0; j < n2 - 2; j++)
			printf(" ");
		//输出最右边的字符,倒着输出
		int k = n3 - i - 1;
		printf("%c\n", right[k]);
	}

	//最后一行
	printf("%s\n", middle);
	system("pause");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值