ACM->poj 2195 Going Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16177 Accepted: 8275

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2

10

28


思路:二分图的最优匹配


#include <iostream>
#include <string.h>
#include <cmath>
#include <algorithm>
#include <stack>
#include <iomanip>

using namespace std;

#define MAXN 100 + 10
#define INF 200000000

int num, tot;

struct House
{
	int x, y;
}house[MAXN];

int temp[MAXN][MAXN];
char c[MAXN][MAXN];
bool visx[MAXN], visy[MAXN];
int lx[MAXN], ly[MAXN], match[MAXN];

int cal(int i, int j, int k)
{
	return abs(i - house[k].x) + abs(j - house[k].y);
}

bool path(int u)
{
	visx[u] = true;
	
	for (int i = 0; i < num; i++)
	{
		if (!visy[i] && lx[u] + ly[i] == temp[u][i])
		{
			visy[i] = true;
			
			if (match[i] == -1 || path(match[i]))
			{
				match[i] = u;				//注意
				return true;
			}
		}
	}
	
	return false;
}

void solve()
{
	memset(lx, 0, sizeof(lx));
	memset(ly, 0, sizeof(ly));
	memset(match, -1, sizeof(match));
	
	for (int i = 0; i < tot; i++)
	{
		for (int j = 0; j < num; j++)
		{
			lx[i] = max(lx[i], temp[i][j]);
		}
	}
	
	for (int i = 0; i < tot; i++)
	{
		while (true)
		{
			memset(visx, false, sizeof(visx));
			memset(visy, false, sizeof(visy));
			
			if (path(i))
			{
				break;
			}
			
			int inc = INF;
			
			for (int i = 0; i < tot; i++)
			{
				if (visx[i])
				{
					for (int j = 0; j < num; j++)
					{
						if (!visy[j] && lx[i] + ly[j] - temp[i][j] < inc)
						{
							inc = lx[i] + ly[j] - temp[i][j];
						}
					}
				}
			}
			
			for (int i = 0; i < tot; i++)
			{
				if (visx[i])
				{
					lx[i] -= inc;
				}
				if (visy[i])
				{
					ly[i] += inc;
				}
			}
		}
	}
	
	int sum = 0;
	
	for (int i = 0; i < tot; i++)
	{
		sum -= temp[match[i]][i];			//注意被弄反了
	}
	
	cout << sum << endl;
}

void input()
{
	int row, col;
	
	while (cin >> row >> col)
	{
		if (!row && !col)
		{
			break;
		}
		
		num = tot = 0;
		
		for (int i = 0; i < row; i++)
		{
			for (int j = 0; j < col; j++)
			{
				cin >> c[i][j];
				
				if (c[i][j] == 'H')
				{
					house[num].x = i;
					house[num++].y = j;
				}
			}
		}
		
		for (int i = 0; i < row; i++)
		{
			for (int j = 0; j < col; j++)
			{
				if (c[i][j] == 'm')
				{
					for (int k = 0; k < num; k++)
					{
						temp[tot][k] = -cal(i, j, k);
					}
					
					tot++;
				}
			}
		}
		
		solve();
	}
}

int main()
{
	input();
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值