poj 2181 Jumping Cows

Description

Farmer John's cows would like to jump over the moon, just like the cows in their favorite nursery rhyme. Unfortunately, cows can not jump.

The local witch doctor has mixed up P (1 <= P <= 150,000) potions to aid the cows in their quest to jump. These potions must be administered exactly in the order they were created, though some may be skipped.

Each potion has a 'strength' (1 <= strength <= 500) that enhances the cows' jumping ability. Taking a potion during an odd time step increases the cows' jump; taking a potion during an even time step decreases the jump. Before taking any potions the cows' jumping ability is, of course, 0.

No potion can be taken twice, and once the cow has begun taking potions, one potion must be taken during each time step, starting at time 1. One or more potions may be skipped in each turn.

Determine which potions to take to get the highest jump.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each line contains a single integer that is the strength of a potion. Line 2 gives the strength of the first potion; line 3 gives the strength of the second potion; and so on.

Output

* Line 1: A single integer that is the maximum possible jump.

Sample Input

8
7
2
1
8
4
3
5
6

Sample Output

17


题目大意:

给p个数:从上至下有序选取,sum = 0,奇数次选取,sum加上选取的数,偶数次选取,减去选取的数,也可以跳过不选,求sum最大为多少。

动态规划题目,彷徨了半天, 不知道如何下手。后来根据题意有奇数的选取和偶数的选取。开了一个dp[2][MAXN]的数组。

手动模拟了以下。

由于奇数次选取是增加的,而偶数次选取是减少的,所以可以肯定,如果要想使sum最大,最后一次选取,必定是奇数次选取。

dp[1][i]表示奇数次选取所能达到的最大值,dp[0][i]表示第i次选取是奇数时,强迫它再进行一次选取所能达到的最大值。(如果不能取或择选取后小于dp[0][i - 1],继承dp[0][i - 1]).

可以看成是dp[0][i]在为dp[1][i]做铺垫。

    dp[1]    dp[0]

0    0          0         //初始都为0;

1    7          0         //dp[1][1]选取第一个数

2    7          5         //dp[0][2]强迫再选一个数所能达到的最大值

3    7          6

4    14        6

5    14        10

6    14        11

7    16        11

8    17        11



#include <iostream>
#include <cstdio>
#define MAXN 150001
#define INF 99999999

using namespace std;

int num[MAXN];
int dp[2][MAXN];

void input()
{
    int n, sum, mi = INF;
    int flag = 0, tot = 1;
    cin >> n;


    for (int i = 1; i <= n; i++)
    {
        scanf("%d", &num[i]);
        if (dp[0][i - 1] + num[i] > dp[1][i - 1])             //选取后大于偶数次则取
        {
            dp[1][i] = dp[0][i - 1] + num[i];
            dp[0][i] = dp[0][i - 1];
        }
        else
        {
            dp[1][i] = dp[1][i - 1];
        }

        dp[0][i] = max(dp[1][i - 1] - num[i], dp[0][i - 1]);   //强迫选取后的最大值
    }

    cout << dp[1][n] << endl;
}

int main()
{
    input();
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值