TOJ 3445 POJ 2192 Zipper

Zipper

时间限制(普通/Java):1000MS/3000MS     运行内存限制:65536KByte
 

描述

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

输入

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

输出

For each data set, print:

 Data set n: yes

if the third string can be formed from the first two, or

 Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

样例输入

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

样例输出

Data set 1: yes
Data set 2: yes
Data set 3: no

 

其实 dfs 剪个枝也行的 代码太恶心 就不写那个搜索的了

#include <stdio.h>  
#include <string>
char a[500],b[500],c[500];
int len1,len2,len3; 
int dp[500][500];//1就是可达 0 不可达 
	
main()
{
	int t,i,j,cas=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s %s %s",a,b,c);
		len1 = strlen(a);
		len2 = strlen(b);
		len3 = strlen(c);
		memset(dp,0,sizeof(dp));
		printf("Data set %d: ",cas++);
		if(a[len1-1] != c[len3-1] && b[len2-1] != c[len3-1] || 
										len1 + len2!=len3 || a[0]!=c[0]&&b[0]!=c[0])
		{
			printf("no\n");
			continue;
		}
		for(i = 1; i<= len1; i++)
		{
			if(a[i-1] == c[i-1])
				dp[i][0] = 1;
		}
		for(i = 1; i<= len2; i++)
		{
			if(b[i-1] == c[i-1])
				dp[0][i] = 1;
		}
		for(i = 1;i <= len1; i++)
		{
			for(j = 1;j <= len2; j++)
			{
				if(dp[i-1][j] && a[i-1] == c[i + j - 1]) 
					dp[i][j] = 1;
				// 当要选a串第i个时必须满足没有选之前也可以组成c的一部分 而且选了也要满足  
				if(dp[i][j-1] && b[j-1] == c[i + j - 1]) 
					dp[i][j] = 1;
				//选a可以 选b的一个字母也可以
			}
		}
		if(dp[len1][len2])
			printf("yes\n");
		else
			printf("no\n");
	}
}  

再来个 搜索吧 比较恶心 比赛时乱打的 没什么风格 不过毕竟是自己写的
#include <stdio.h>  
#include <string>
char a[500],b[500],c[500];
int len1,len2,len3; 
int dp[500][500];
int flag;
void dfs(int s1,int s2,int s3)
{
	//printf("%d %d\n",s1,s2);
	if(flag)
		return;
	if(s1==len1&&s2==len2&&s3==len3)
	{
		flag = 1;
		return;
	}
	if(s1>len1||s2>len2||s3>len3)
		return ;
	if(a[s1] == c[s3]&&s1<len1&&s3<len3)
	{
		dfs(s1+1,s2,s3+1);
	}
	if(b[s2] == c[s3]&&s2<len2&&s3<len3)
	{
		dfs(s1,s2+1,s3+1);
	}
	return;
}
main()
{
	int t,i,j,k,cas=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s %s %s",a,b,c);
		len1 = strlen(a);
		len2 = strlen(b);
		len3 = strlen(c);
		memset(dp,0,sizeof(dp));
		flag = 0;
		printf("Data set %d: ",cas++);
		if(a[len1-1]!=c[len3-1]&&b[len2-1]!=c[len3-1] || len1+len2!=len3)
		{
			printf("no\n");
			continue;
		}
		dfs(0,0,0);
		if(flag)
			printf("yes\n");
		else
			printf("no\n");
	
	}
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值