hdu 4006 The kth great number

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 6146    Accepted Submission(s): 2484


Problem Description

 

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 


 

Input

 

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.  
 


 

Output

 

The output consists of one integer representing the largest number of islands that all lie on one line.  
 


 

Sample Input

 

  
  
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 


 

Sample Output

 

  
  
1 2 3
Hint
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).

 

 

解题思路:刚开始做是模拟一个数组,只存前K大的元素,每输入一个数比较一下大小,判断要不要这个数,思路很简单。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define N 1000010
static int a[N];
int n,k,m;
int cmp(const void *a,const void*b)
{
    return *(int *)a>*(int *)b?-1:1;   //大数在前
}
void inti(int t)
{
    int i,j;
    if(m<k)       // 先把数加入数组中
        a[m++]=t;
    else if(m==k)
    {
        a[m++]=t;
        qsort(a,m,sizeof(a[0]),cmp);
    }
    else
    {
        if(t>a[k])               //当数组元素大于k时,去掉最小的数
        {
            for(i=k;i>=0;i--)
                if(a[i]>t)
                    break;
            for(j=k;j>i+1;j--)
                a[j]=a[j-1];
            a[i+1]=t;
        }
    }
}
int main()
{
    int t;
    char ch;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        k--;
        getchar();
        m=0;
        while(n--)
        {
            scanf("%c",&ch);
            if(ch=='I')
            {
                scanf("%d",&t);
                inti(t);
            }
            else
                printf("%d\n",a[k]);
            getchar();
        }
    }
    return 0;
}


 

可以直接用优先队列实现,按照数的大小为优先级,

 

#include"stdio.h"
#include"queue"
using namespace std;
struct node 
{
    int x;
    friend bool operator<(node a,node b)
    {
        return a.x>b.x;
    }
};
int main()
{
    int n,k,i,y;
    char ch;
    while(scanf("%d%d",&n,&k)!=-1)
    {
        priority_queue<node>q;
        node p;
        while(n--)
        {
            getchar();
            scanf("%c",&ch);
            if(ch=='I')
            {
                scanf("%d",&i);
                p.x=i;
                q.push(p);
                y=q.size();
                if(q.size()>k)
                    q.pop();
                y=q.size();
            }
            else
            {
                p=q.top();
                printf("%d\n",p.x);
            }
        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值