hdu 1297 Children’s Queue

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9549    Accepted Submission(s): 3053


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 4

解题思路:

一个长度n的队列可以看成一个n - 1的队列再追加的1个小孩,这个小孩只可能是:

a.男孩,任何n - 1的合法队列追加1个男孩必然是合法的,情况数为f[n - 1];

b.女孩,在前n - 1的以女孩为末尾的队列后追加1位女孩也是合法的,我们可以转化为n - 2的队列中追加2位女孩;

一种情况是在n - 2的合法队列中追加2位女孩,情况数为f[n - 2];

但我们注意到本题的难点,可能前n - 2位以女孩为末尾的不合法队列(即单纯以1位女孩结尾),也可以追加2位女孩成为合法队列,而这种n - 2不合法队列必然是由n - 4合法队列+1男孩+1女孩的结构,即情况数为f[n - 4]。

得出递推公式:f[n]=f[n-1]+f[n-2]+f[n-4];


代码如下:

#include"stdio.h"
#include"string.h"
#define N 1000
#define M 10000
int main()
{         
int i,j,n,len=100;
int f[N][100];
memset(f,0,sizeof(f));
f[0][0]=1;
f[1][0]=2;
f[2][0]=4;
f[3][0]=7;
for(i=4;i<N;i++)
{
for(j=0;j<len;j++)
{
f[i][j]+=f[i-1][j]+f[i-2][j]+f[i-4][j];              //应用递推公式,注意进位
f[i][j+1]+=f[i][j]/M;                          //每个数位存储0--9999大小的数
f[i][j]%=M;
}
}
while(scanf("%d",&n)!=-1)
{
i=len-1;
while(!f[n-1][i--]);            //这个很不错啊!  找出最高位数字
printf("%d",f[n-1][i+1]);
for(;i>=0;i--)
printf("%04d",f[n-1][i]);        //不足四个数字的补零占够位数
puts("");              //换行
}
return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值