poj 1860 Currency Exchange (最短路变形-spfa)

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 18295 Accepted: 6448

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

解题思路:如果存在正环,那么一定是YES;因为若没有正环每类钱币最多入队n次,(和该币值可以交换的最多n-1种)所以若某类钱币入队大于n次就存在正环。


#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define N 105
int n,mark[N];  //mark[]记录该类钱币是否在队列里
int visit[N],s;        //visit[]记录每个点入队的次数
double dis[N],v;  //dis[]记录原点到其他点的值
struct node
{
	int f;      
	double c,r;
}map[N][N];       //map[i][j].f为1,代表i类钱币可以换成j类
int spfa()
{
	int i,cur;
	queue<int>q;
	memset(mark,0,sizeof(mark));
	memset(visit,0,sizeof(visit));
	memset(dis,0,sizeof(dis));
	mark[s]=1;
	visit[s]=1;
	dis[s]=v;
	q.push(s);
	while(!q.empty())
	{
		cur=q.front();
		mark[cur]=0;
		q.pop();
		for(i=1;i<=n;i++)
		{
			if(map[cur][i].f)      //可以交换币种
			{
				if(dis[i]<(dis[cur]-map[cur][i].c)*map[cur][i].r)      
				{
					dis[i]=(dis[cur]-map[cur][i].c)*map[cur][i].r;
					if(!mark[i])               //队列里没有该钱币种类
					{
						mark[i]=1;
						visit[i]++;        
						if(visit[i]>n)
							return 1;
						q.push(i);
					}
				}
			}
		}
	}
	return 0;
}
int main()
{
	int m,a,b;
	double c,d,e,f;
	while(scanf("%d%d%d%lf",&n,&m,&s,&v)!=-1)
	{
		memset(map,0,sizeof(map));
		while(m--)
		{
			scanf("%d%d%lf%lf%lf%lf",&a,&b,&c,&d,&e,&f);
			map[a][b].f=1;
			map[a][b].r=c;
			map[a][b].c=d;
			map[b][a].f=1;
			map[b][a].r=e;
			map[b][a].c=f;
		}
		if(spfa())
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值