hdu 1541 Stars(模板)

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4402    Accepted Submission(s): 1748


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0
 

树状数组入门题:

输入按y坐标递增的,y坐标相同则按x坐标递增;每输入一个点,可以统计出(x,y)左下方的所有点个数(即横坐标小于x),然后更新横坐标大于x的各点值。

#include"stdio.h"
#include"string.h"
#define N 32005
int ans[N],c[N];
int lowbit(int i)  //利用机器补码特性,-x 是x 的补码;补码为取反+1
{
    return i&(-i);
}
int getsum(int x)  //统计出横坐标小于等于x的点个数
{
    int i,sum=0;
    for(i=x;i>0;i-=lowbit(i))  //减去二进制的末位1,最多log(n)次
    {
        sum+=c[i];
    }
    return sum;
}
void modify(int x,int d)      //更新横坐标大于等于x的点个数
{
    int i;
    for(i=x;i<N;i+=lowbit(i))
        c[i]+=d;
}
int main()
{
    int i,n,x,y;
    while(scanf("%d",&n)!=-1)
    {
        memset(c,0,sizeof(c));
        memset(ans,0,sizeof(ans));
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            x++;          //x++的原因:如果x=0更新时就会出现死循环所以都++
            ans[getsum(x)]++;
            modify(x,1);
        }
        for(i=0;i<n;i++)
        {
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值