hdu 1024 Max Sum Plus Plus (子段和最大问题)

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17336    Accepted Submission(s): 5701


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.


给定一个数组,求M段连续的子段和最大。dp[i][j]表示前i段选择第j个元素的最优解。

dp[i][j]=max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j

因为k<j,所以我们可以用两个一维数组,一个dp[i]记录当前行状态,一个d[i]记录下一行可选的最大值;

用64位会超时,但int能水过。。

</pre><pre name="code" class="cpp">/*
dp[i][j]=max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j
第j个元素选i段区间,对于当前元素a[j],可以把它接到第i段的第j-1位置构成一段,
或者单独成一段。
观察这个方程,对于dp[i][j-1]这一项,它和dp[i][j]同i,就是在一段,
用一维数组就能记录;
dp[i-1][k]是i-1段j位置前能取的最大值,我们可以在计算当前第i段时,
把dp[i-1][k]记录下来,取最大值就好了。
*/

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define ll __int64
const int inf=0x7fffffff;
#define N 1000010
int a[N];
int pre[N];        //即dp[i-1][k],记录j位置前可选值
int dp[N];
int main()
{
    int i,j,n,m;
    int tmp,ans;
    while(~scanf("%d%d",&m,&n))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            dp[i]=0;
            pre[i]=0;
        }
        pre[0]=dp[0]=0;
        ans=-inf;
        for(i=1;i<=m;i++)
        {
            tmp=-inf;
            for(j=i;j<=n;j++)
            {
                dp[j]=max(dp[j-1]+a[j],pre[j-1]+a[j]);
                pre[j-1]=tmp;      //tmp记录的是当前段j位置的最大值,
                tmp=max(tmp,dp[j]);//而数组pre[]是记录j-1位置的,所以要先取tmp,再更新tmp
            }
        }
        for(i=m;i<=n;i++)
            ans=max(ans,dp[i]);
        printf("%d\n",ans);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值