hdu 1158 Employment Planning

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3971    Accepted Submission(s): 1645


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project. 
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
  
  
3 4 5 6 10 9 11 0
 

Sample Output
  
  
199

简单dp,主要没有给出最大雇佣员工数目,当做200足够了。然后,找出当前月雇佣员工和上个月雇佣员工转化关系就好了。


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<map>
using namespace std;
#define N 15
#define M 200
#define ll __int64
const int inf=0x7fffffff;
int a[N],mmax,n;
int dp[N][M];
void inti()       
{
    int i,j;
    for(i=0;i<=n;i++)
        for(j=0;j<=mmax;j++)
        dp[i][j]=inf;
}
int main()
{
    int i,j,k,add,sal,fire;
    while(scanf("%d",&n),n)
    {
        scanf("%d%d%d",&add,&sal,&fire);
        for(i=1,mmax=0;i<=n;i++)
        {
            scanf("%d",&a[i]);
            mmax=max(mmax,a[i]);
        }
        inti();
        for(i=a[1];i<=mmax;i++)
            dp[1][i]=(add+sal)*i;
        for(i=2;i<=n;i++)
        {
            for(j=a[i-1];j<=mmax;j++) //上个月合法雇人数目
            {
                for(k=a[i];k<=mmax;k++)  //这个月合法雇人数目
                {
                    if(k<j)
                        dp[i][k]=min(dp[i][k],dp[i-1][j]+(j-k)*fire+k*sal);
                    else
                        dp[i][k]=min(dp[i][k],dp[i-1][j]+(k-j)*add+k*sal);
                }
            }
        }
        int ans=inf;
        for(i=a[n];i<=mmax;i++)
            ans=min(ans,dp[n][i]);
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值