【PAT】【Advanced Level】1127. ZigZagging on a Tree (30)

14 篇文章 0 订阅
8 篇文章 0 订阅

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
原题链接:

https://www.patest.cn/contests/pat-a-practise/1127

思路:

建树,然后层序排序,针对层数相同的,奇数层按中序遍历次序的降序排序,偶数层按中序遍历的升序排序。

CODE:

#include<iostream>
#include<vector>
#include<algorithm>
#define N 31
using namespace std;
typedef struct S
{
	int val;
	int ls;
	int rs;
	int fl;
	int tra;
};
vector<S> T;
int in[N];
int po[N];
void dfs(int l1,int r1,int l2 ,int r2,int flo)
{
	if (l1==r1)
	{
		S ne;
		ne.val=in[l1];
		ne.fl=flo;
		ne.tra=l1;
		T.push_back(ne);
		return ;
	}
	int pos;
	for(int i=l1;i<=r1;i++)
	{
		if (in[i]==po[r2])
		{
			pos=i;
			break;
		}
	}
	int le1=pos-l1;
	int le2=r1-pos;
	if (pos!=l1)
	{
		dfs(l1,pos-1,l2,l2+le1-1,flo+1);	
	}
	S ne;
	ne.val=in[pos];
	ne.fl=flo;
	ne.tra=pos;
	T.push_back(ne);
	if (pos!=r1)
	{
		dfs(pos+1,r1,l2+le1,r2-1,flo+1);
	}
}
bool cmp(S a, S b)
{
	if (a.fl==b.fl)
	{
		if (a.fl%2==1)
		{
			return a.tra>b.tra;
		}
		else
		{
			return a.tra<b.tra;
		}
	}
	else
	{
		return a.fl<b.fl;
	}	
}
int main()
{
	int n;
	cin>>n;
	for (int i=0;i<n;i++) cin>>in[i];
	for (int i=0;i<n;i++) cin>>po[i];
	dfs(0,n-1,0,n-1,1);
	sort(T.begin(),T.end(),cmp);
	for (int i=0;i<n;i++)
	{
		if (i!=0) cout<<" ";
		cout<<T[i].val;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值