Radar题目及解法

Radar

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1


贪心策略:

按照b1<=b2<=b3…(b相同时按a从大到小)的方式排序排序,从前向后遍历,当遇到没有加入集合的区间时,选取这个区间的右端点b。

证明:

为了方便起见,如果区间i内已经有一个点被取到,我们称区间i被满足。

1、首先考虑区间包含的情况,当小区间被满足时大区间一定被满足。所以我们应当优先选取小区间中的点,从而使大区间不用考虑。

      按照上面的方式排序后,如果出现区间包含的情况,小区间一定在大区间前面。所以此情况下我们会优先选择小区间。

      则此情况下,贪心策略是正确的。

2、排除情况1后,一定有a1<=a2<=a3……。


      对于区间1来说,显然选择它的右端点是明智的。因为它比前面的点能覆盖更大的范围。

      从而此情况下,贪心策略也是正确的。

#include <iostream>
#include <string.h>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=1010;

struct N
{
  double l,r;
}interval[maxn];

bool cmp(N a,N b)//排序
{
  if(a.r<b.r)
    return true;
  else if(a.r==b.r)
  {
    if(a.l>b.l)
      return true;
    return false;
  }
  return false;
}


int main()
{
  double x,y;
  int n,d;
  int c=1;
  while(cin>>n>>d&&(n||d))
  {
    bool ok=1;
    for(int i=1;i<=n;i++)
    {
      cin>>x>>y;
      double temp=d*d-y*y;
      if(temp<0||d<0)
        ok=0;
      else if(ok)
      {
        interval[i].l=x-sqrt((double)d*d - (double)y*y);
        interval[i].r=x+sqrt((double)d*d - (double)y*y);
      }
    }
    if(!ok)
    {
      cout<<"Case "<<c++<<": "<<-1<<endl;
      continue;
    }
    sort(interval+1,interval+1+n,cmp);
    int cnt=1;
    double temp=interval[1].r;
    for(int i=2;i<=n;i++)
    {
      if(temp<interval[i].l)
      {
        cnt++;
        temp=interval[i].r;
      }
      
    }
    
    cout<<"Case "<<c++<<": "<<cnt<<endl;
  }
  return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值