扩展二叉树(信息学奥赛一本通-T1340)

【题目描述】

由于先序、中序和后序序列中的任一个都不能唯一确定一棵二叉树,所以对二叉树做如下处理,将二叉树的空结点用·补齐,如图所示。我们把这样处理后的二叉树称为原二叉树的扩展二叉树,扩展二叉树的先序和后序序列能唯一确定其二叉树。

现给出扩展二叉树的先序序列,要求输出其中序和后序序列。

【输入】

扩展二叉树的先序序列。

【输出】

输出其中序和后序序列。

【输入样例】

ABD..EF..G..C..

【输出样例】

DBFEGAC
DFGEBCA

【源程序】

#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <queue>
#include <string>
#include <vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 101
#define MOD 123
#define E 1e-6
using namespace std;
typedef struct Node;
typedef Node *tree;
struct Node {
    char data;
    tree lchild, rchild;
};
tree bt;
int i = -1;
string s;
void build(tree &bt) //建树
{
    if (s[++i] != '.') {
        bt = new Node;
        bt = new Node;
        bt->data = s[i];
        build(bt->lchild);
        build(bt->rchild);
    } else
        bt = NULL;
}
void inorder(tree bt) //输出中序序列
{
    if (bt) {
        inorder(bt->lchild);
        cout << bt->data;
        inorder(bt->rchild);
    }
}
void postorder(tree bt) //输出后序序列
{
    if (bt) {
        postorder(bt->lchild);
        postorder(bt->rchild);
        cout << bt->data;
    }
}
int main() {
    cin >> s;
    build(bt);
    inorder(bt);
    cout << endl;
    postorder(bt);
    cout << endl;
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值