Most Powerful(ZOJ-3471)

Problem Description

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input 

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22

题意:不超过10种气体,两两之间相互碰撞可以产生一定的能量,a 碰 b,b 会就消失,同一种类不能碰撞,求能得到的最大能量

思路:

用 10 位二进制表示气体是否存在,0 表示存在,1表示不存在,上一个状态中的两种气体碰撞并且有一种消失,可以得到新的状态,用 dp[state] 表示状态为 state 时的最大能量,则有转移方程:dp[state] = max(dp[state],dp[pre_state]+a[i][j])

Source Program

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<ctime>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 1001
#define MOD 100000000
#define E 1e-6
#define LL long long
using namespace std;
int a[10][10];
int dp[1<<10];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                cin>>a[i][j];

        for(int s=0;s<(1<<n);s++)
        {
            for(int i=0;i<n;i++)
            {
                if(s&(1<<i))
                    continue;

                for(int j=0;j<n;j++)
                {
                    if(i==j)
                        continue;
                    if(s&(1<<j))
                        continue;

                    int new_state=s+(1<<j);//下一状态
                    dp[new_state]=max(dp[new_state],dp[s]+a[i][j]);
                }
            }
        }

        int maxx=-INF;
        for(int i=0;i<(1<<n);i++)
            maxx=max(maxx,dp[i]);
        printf("%d\n",maxx);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值