HDU 1150&&POJ 1325解题报告

Machine Schedule

                                               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                        Total Submission(s): 6314    Accepted Submission(s): 3162


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
  
  
3
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1068  1151  1281  1507  1528 

           这道题是比较经典的最小顶点覆盖问题。但是建图比较难想。在本题中需要转换思维。最开始我是把任务当成一个集合,A机器的模式与B机器的模式分别与任务集合进行连边。但是这样操作发现是不对的。原因是A,B机器的模式与任务对应时是或的关系,即从两个机器的两个模式中任选一个。而一旦该模式与任务连了边,那么说明该任务就对应该机器的该模式。这样就无法体现是从A,B两台机器中任选一台机器的模式。而是将A,B之间的关系变成了且,而不是或。

        所以要转换思路。由于A,B之间具有独立关系,而且A和B中每次只能选取一个。所以我们可以把A和B集合看成二分图的两个部分,将任务看成它们的边。这样要选取最少的点覆盖所有的边,即覆盖所有的任务。所以属于最小顶点覆盖。

       由定理可知,最小顶点覆盖数=二分图最大匹配数

          下面是参考代码:

       

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#define pb push_back
#define CLR(x) memset(x,0,sizeof(x))
#define __CLR(x) memset(x,-1,sizeof(x))
using namespace std;

vector<int>G[210];
int match[1010];
bool vis[210];

bool dfs(int u)
{
    for(int i=0;i<G[u].size();i++)
    {
        int t=G[u][i];
        if(!vis[t])
        {
            vis[t]=1;
            if(match[t]==-1||dfs(match[t]))
            {
                match[t]=u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
   //ios_base::sync_with_stdio(0);
   int n,m,k;
   while(~scanf("%d",&n)&&n)
   {
       scanf("%d%d",&m,&k);
       for(int p=0;p<k;p++)
       {
           int i,x,y;
           scanf("%d%d%d",&i,&x,&y);
           if(x&&y)                 //在POJ上要加上这句话,否则会WA
              G[x].pb(y);
       }
       __CLR(match);
       int num=0;
       for(int i=1;i<n;i++)     //注意是从1开始的,模式0不需要重启
       {
           CLR(vis);
           if(dfs(i))
              num++;
       }
       printf("%d\n",num);
       for(int i=0;i<210;i++)
          G[i].clear();
   }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值