Magic Box

时间限制:10000ms
单点时限:1000ms
内存限制:256MB
描述
The circus clown Sunny has a magic box. When the circus is performing, Sunny puts some balls into the box one by one. The balls are in three colors: red(R), yellow(Y) and blue(B). Let Cr, Cy, Cb denote the numbers of red, yellow, blue balls in the box. Whenever the differences among Cr, Cy, Cb happen to be x, y, z, all balls in the box vanish. Given x, y, z and the sequence in which Sunny put the balls, you are to find what is the maximum number of balls in the box ever.

For example, let’s assume x=1, y=2, z=3 and the sequence is RRYBRBRYBRY. After Sunny puts the first 7 balls, RRYBRBR, into the box, Cr, Cy, Cb are 4, 1, 2 respectively. The differences are exactly 1, 2, 3. (|Cr-Cy|=3, |Cy-Cb|=1, |Cb-Cr|=2) Then all the 7 balls vanish. Finally there are 4 balls in the box, after Sunny puts the remaining balls. So the box contains 7 balls at most, after Sunny puts the first 7 balls and before they vanish.

输入
Line 1: x y z

Line 2: the sequence consisting of only three characters ‘R’, ‘Y’ and ‘B’.

For 30% data, the length of the sequence is no more than 200.

For 100% data, the length of the sequence is no more than 20,000, 0 <= x, y, z <= 20.

输出
The maximum number of balls in the box ever.

提示
Another Sample

Sample Input Sample Output
0 0 0
RBYRRBY 4

样例输入
1 2 3
RRYBRBRYBRY
样例输出
7

#include "stdio.h"
#include "string.h"
#include "algorithm"
using namespace std;

int condition[3];

int ok(int count[3])
{
    int result[3] = {abs(count[0]-count[1]), abs(count[1]-count[2]), abs(count[2]-count[0])};
    sort(result, result+3);
    sort(condition, condition+3);
    if(condition[0]==result[0] && condition[1]==result[1] && condition[2]==result[2])
        return 1;
    return 0;
}

int sum(int count[3])
{
    return count[0] + count[1] + count[2];
}

int main()
{
    scanf("%d%d%d", &condition[0], &condition[1], &condition[2]);
    char color[200001];
    scanf("%s", color);
    int len = strlen(color);

    int count[3] = {0, 0, 0};  // 初始化计数器
    int max = 0;  // 初始化最大值

    int i, j;
    int total = 0;
    int last = 0;
    for(i=0; i<len; i++)  
    {
        switch(color[i])
        {
        case 'R':
            count[0]++;
            break;
        case 'Y':
            count[1]++;
            break;
        case 'B':
            count[2]++;
            break;
        }
        if(ok(count))  //count满足消除条件
        {
            total = sum(count);  //统计当前有多少球
            if(max < total)
                max = total;

            for(j=0; j<3; j++)     // 重置计数器
                count[j] = 0;
            last = i+1;
        }
    }

    max = max > len-last? max : len-last;
    printf("%d", max);

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值