HDU-1242 Rescue

22 篇文章 0 订阅

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
Sample Output
   
   
13

 ————————————————————集训1.2的分割线————————————————————

思路:复习BFS。这道题不一样的是每个点消耗的时间不一样。要求最短时间到达终点。需要开一个新的数组min_time[][]记录走到每个点的最短时间。(隐约感到记忆化搜索也可以写吧)队列的元素可以采用结构体储存位置和走到该点最短时间。每次入队的都是产生更优解的点。

代码如下:

/*
ID: j.sure.1
PROG: 
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <iostream>
using namespace std;
/****************************************/
#define LIM nx >= 0 && nx < n && ny >= 0 && ny < m
const int N = 205;
const int d[][2] = {{-1, 0}, {0, 1}, {1, 0}, {0, -1}};
char mat[N][N];
int min_t[N][N];
int n, m, ex, ey;
struct Node
{
	int x, y;
	int time;
};
queue <Node> q;

int bfs(Node &st)
{
	q.push(st);
	Node tmp;
	while(!q.empty()) {
		tmp = q.front(); q.pop();
		for(int i = 0; i < 4; i++) {
			int nx = tmp.x + d[i][0], ny = tmp.y + d[i][1];
			if(LIM && mat[nx][ny] != '#') {
				Node nt;
				nt.x = nx; nt.y = ny;
				nt.time = tmp.time + 1;
				if(mat[nx][ny] == 'x') nt.time++;
				if(nt.time < min_t[nx][ny]) {
					min_t[nx][ny] = nt.time;
					q.push(nt);
				}
			}
		}
	}
	return min_t[ex][ey];
}

int main()
{
	#ifndef ONLINE_JUDGE
	freopen("1242.in", "r", stdin);
	freopen("1242.out", "w", stdout);
	#endif
	while(~scanf("%d%d", &n, &m)) {
		getchar();
		Node st;
		for(int i = 0; i < n; i++) {
			for(int j = 0; j < m; j++) {
				scanf("%c", &mat[i][j]);
				min_t[i][j] = 2e9;
				switch(mat[i][j])
				{
					case 'r': st.x = i; st.y = j; min_t[i][j] = st.time = 0; break;
					case 'a': ex = i; ey = j; break;
				}
			}
			getchar();
		}
		int ans = bfs(st);
		if(ans == 2e9)
			puts("Poor ANGEL has to stay in the prison all his life.");
		else
			printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值