hdu Rescue

算法:搜索

题意:要求天使的朋友在最短的时间内救出天使,a代表天使,r代表天使的朋友,.代表路,#代表墙,x代表小兵,

每走一步需要一个时间,遇到小兵杀了他要一个时间,移到小兵的位置有要一个时间;

输出最短的时间,

如果救不出来就输出

Poor ANGEL has to stay in the prison all his life.

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)


Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.


Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."


Sample Input
7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........


Sample Output
13

代码:

#include <iostream>
#include <algorithm>
#include <string>
#include <iomanip>
#include <cstring>
#include <stdio.h>
#define INF 100000
using namespace std;
char ch[205][205];
int a[205][205],n,m,k,q=-1,p=-1;
int b[4][2]={-1,0,1,0,0,-1,0,1};
void dfs(int x,int y)
{   int j=0;
	if(x==p&&y==q) return;
	else
	{
		for(int i=0;i<4;i++)
		{
			int dx=x+b[i][0];
			int dy=y+b[i][1];
			if(dx>=0&&dx<n&&dy>=0&&dy<m&&ch[dx][dy]=='.'||ch[dx][dy]=='x')
			{
				if(ch[dx][dy]=='.')
				{
					ch[dx][dy]='#';
					a[dx][dy]=min(a[x][y]+1,a[dx][dy]);
					dfs(dx,dy);
					ch[dx][dy]='.';
				}
				else if(ch[dx][dy]=='x')
				{
				    ch[dx][dy]='#';
					a[dx][dy]=min(a[x][y]+2,a[dx][dy]);
					dfs(dx,dy);
					ch[dx][dy]='x';	
				}
			}
			else j++;
		}
		if(j==4) return ;
	}
}  
int main()
{
	int i,j,s,t;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
		 		cin>>ch[i][j];
				a[i][j]=INF;
				if(ch[i][j]=='a')
				{
					s=i;t=j;
					ch[i][j]='#';
				}
				if(ch[i][j]=='r')
				{
				    p=i;q=j;
					ch[i][j]='.';	
				}
			}
		}
		a[s][t]=0;
		dfs(s,t);
		if(a[p][q]==INF) printf("Poor ANGEL has to stay in the prison all his life.\n");
		else printf("%d\n",a[p][q]);
	}
	return 0;
}


  

转载于:https://www.cnblogs.com/wangyumin/p/5323455.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值