hdu Rescue

 

Rescue

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."


Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........
Sample Output

13

 

题意:  就是从 r——》a  的最短时间,x为守卫,消灭他需要花费时间  走一步和 消灭守卫 花的时间都是 1s。

          这里 我们就得用到优先队列,还有一个问题就是 题目中是each of friend 我这就是又a——》r 的最短

          很直接的一个带优先队列的bfs。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

int s1,s2,e1,e2,n,m,f[210][210];
char ma[210][210];
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};

typedef struct node
{
    int x,y,time;
    friend bool operator < (const node &a,const node &b)
    {
        return a.time>b.time;
    }
}cur;

priority_queue <node > vis;
int judge(int a,int b)
{
    if(a>=0&&a<n&&b>=0&&b<m&&f[a][b]&&ma[a][b]!='#')
    {
        f[a][b]=0;
        return 1;
    }
    return 0;

}
int bfs(int x,int y)
{
    node cur,next;
    while(!vis.empty())
    {
        cur=vis.top();  vis.pop();
        for(int i=0;i<4;i++)
        {
            next.x=cur.x+dir[i][0]; next.y=cur.y+dir[i][1];
            if(judge(next.x,next.y))
            {
                if(ma[next.x][next.y]=='r')
                    return cur.time+1;
                if(ma[next.x][next.y]=='x')
                    next.time=cur.time+2;
                else
                    next.time=cur.time+1;
                vis.push(next);
            }
        }
    }
    return -1;
}
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                cin>>ma[i][j];
                if(ma[i][j]=='r')
                    s1=i,s2=j;
                else if(ma[i][j]=='a')
                    e1=i,e2=j;
                f[i][j]=1;
            }
        }
        node en;
        en.x=e1,en.y=e2,en.time=0;
        vis.push(en);
        f[e1][e2]=0;
        int time=bfs(e1,e2);
        while(!vis.empty())
            vis.pop();
        if(time<0)
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        else
            printf("%d\n",time);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值