POJ-3259 Wormholes

14 篇文章 0 订阅
Wormholes
Time Limit: 2000MS Memory Limit: 65536K

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
————————————————————集训13.5的分割线————————————————————
思路:判断是否存在负环,用SPFA的话只需要在某个点入队次数大于n的时候return true就行了。
另外还把STL的queue改成了手写的循环队列。每次调用头和尾坐标的时候取余一下就行了。
水题不解释。
代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <climits>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
/****************************************/
const int N = 505, M = 2505, W = 205, MAXN = 2000;
int n, m, hole, tot, head[N], dis[N], enq[N];
bool inq[N];
int q[MAXN];
struct Node
{
    int u, v, w, next;
}edge[M*2+W];

void init()
{
    memset(head, -1, sizeof(head));
    tot = 0;
}

void add(int u, int v, int w)
{
    edge[tot].u = u;
    edge[tot].v = v;
    edge[tot].w = w;
    edge[tot].next = head[u];
    head[u] = tot++;
}

bool spfa(int st)
{
	for(int i = 1; i <= n; i++) {
		dis[i] = INF;
		inq[i] = false;
		enq[i] = 0;
	}
    int fron = 0, rear = 1;
    q[fron] = st;
    enq[st]++;
	dis[st] = 0;
    inq[st] = true;
    while(fron < rear) {
        int u = q[fron%MAXN];
		fron++;
        inq[u] = false;
        for(int i = head[u]; i != -1; i = edge[i].next) {
            int v = edge[i].v;
            if(dis[v] > dis[u] + edge[i].w) {
                dis[v] = dis[u] + edge[i].w;
                if(!inq[v]) {
                    q[rear%MAXN] = v;
					rear++;
					enq[v]++;
					if(enq[v] > n) return  true;
                    inq[v] = true;
                }
            }
        }
    }
	return false;
}

int main()
{
#ifdef J_Sure
	freopen("000.in", "r", stdin);
//	freopen(".out", "w", stdout);
#endif
	int T;
	scanf("%d", &T);
	while(T--) {
		init();
		scanf("%d%d%d", &n, &m, &hole);
		int u, v, w;
		while(m--) {
			scanf("%d%d%d", &u, &v, &w);
			add(u, v, w);
			add(v, u, w);
		}
		while(hole--) {
			scanf("%d%d%d", &u, &v, &w);
			add(u, v, -w);
		}
		if(spfa(1)) puts("YES");
		else puts("NO");
	}
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值