HDU-3555 Bomb

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

 ————————————————————集训20.1的分割线————————————————————

思路:水题一枚,数位DP,记录前一位是不是4,记录是否出现了"49"即可。注意使用%I64d

代码如下:

/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <iostream>
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
/****************************************/
int num[20];
LL dp[20][2][2];

LL dfs(int len, bool pre, bool bomb, bool bnd)
{
	if(len == 0) {
		if(bomb) return 1;
		return 0;
	}
	if(!bnd && dp[len][pre][bomb] != -1)
		return dp[len][pre][bomb];
	int lim = (bnd ? num[len] : 9);
	LL ret = 0;
	for(int k = lim; k >= 0; k--) {
		ret += dfs(len-1, k==4, bomb || (pre&&k==9), bnd && k==lim);
	}
	if(!bnd) dp[len][pre][bomb] = ret;
	return ret;
}

LL Solve(LL x)
{
	int cnt = 0;
	while(x) {
		num[++cnt] = x % 10;
		x /= 10;
	}
	return dfs(cnt, false, false, true);
}

int main()
{
#ifdef J_Sure
//	freopen("000.in", "r", stdin);
//	freopen(".out", "w", stdout);
#endif
	LL n;
	int T;
	memset(dp, -1, sizeof(dp));
	scanf("%d", &T);
	while(T--) {
		scanf("%I64d", &n);
		printf("%I64d\n", Solve(n));
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值